const regex = /^\s*(?P<hop>\d+)\s+(?P<dest>([^*[ ]+))(\s*\[(?P<dest_ip>\d+\.\d+\.\d+\.\d+)\])?\s*reports[:].*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(?P<hop>\\d+)\\s+(?P<dest>([^*[ ]+))(\\s*\\[(?P<dest_ip>\\d+\\.\\d+\\.\\d+\\.\\d+)\\])?\\s*reports[:].*', 'g')
const str = ` 8 att.com [144.160.36.42] reports: Destination protocol unreachable.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}