package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*(?P<hop>\d+)\s+(?P<dest>([^*[ ]+))(\s*\[(?P<dest_ip>\d+\.\d+\.\d+\.\d+)\])?\s*reports[:].*`)
var str = ` 8 att.com [144.160.36.42] reports: Destination protocol unreachable.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}