// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[(?<content_type>\w+):(?<parameter>\w+)(?::(?<options>[^]]+))?\]").unwrap();
let string = "Title is [site:hello:value:keep:going]
[job_alert_schedule:template]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}