package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[(?<content_type>\w+):(?<parameter>\w+)(?::(?<options>[^]]+))?\]`)
var str = `Title is [site:hello:value:keep:going]
[job_alert_schedule:template]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}