$re = '/\[(?<content_type>\w+):(?<parameter>\w+)(?::(?<options>[^]]+))?\]/m';
$str = 'Title is [site:hello:value:keep:going]
[job_alert_schedule:template]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);