package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\sUTC[+|-][0-9]+`)
var str = ` UTC+1
UTC+11
UTC-11`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}