using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\sUTC[+|-][0-9]+";
string input = @" UTC+1
UTC+11
UTC-11";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}