use strict;
my $str = 'User initiated logoff: Subject: Security ID: S-1-5-21-2625066280-1555652605-4253891054-500 Account Name: administrator Account Domain: LANDBW Logon ID: 0xb173ce This event is generated when a logoff is initiated. No further user-initiated activity can occur. This event can be interpreted as a logoff event.';
my $regex = qr/(?P<event_message>User initiated logoff:)\s+Subject:\s+Security ID:\s+(?P<subject_security_id>.*?)\s+Account Name:(?P<subject_account_name>.*?)\s+Account Domain:\s+(?P<subject_account_domain>.*?)\s+Logon ID:\s+(?P<subject_logon_id>.*?)\s+(?P<event_details>.*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}