const regex = /(?P<event_message>User initiated logoff:)\s+Subject:\s+Security ID:\s+(?P<subject_security_id>.*?)\s+Account Name:(?P<subject_account_name>.*?)\s+Account Domain:\s+(?P<subject_account_domain>.*?)\s+Logon ID:\s+(?P<subject_logon_id>.*?)\s+(?P<event_details>.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<event_message>User initiated logoff:)\\s+Subject:\\s+Security ID:\\s+(?P<subject_security_id>.*?)\\s+Account Name:(?P<subject_account_name>.*?)\\s+Account Domain:\\s+(?P<subject_account_domain>.*?)\\s+Logon ID:\\s+(?P<subject_logon_id>.*?)\\s+(?P<event_details>.*)', 'g')
const str = `User initiated logoff: Subject: Security ID: S-1-5-21-2625066280-1555652605-4253891054-500 Account Name: administrator Account Domain: LANDBW Logon ID: 0xb173ce This event is generated when a logoff is initiated. No further user-initiated activity can occur. This event can be interpreted as a logoff event.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}