using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<event_message>User initiated logoff:)\s+Subject:\s+Security ID:\s+(?P<subject_security_id>.*?)\s+Account Name:(?P<subject_account_name>.*?)\s+Account Domain:\s+(?P<subject_account_domain>.*?)\s+Logon ID:\s+(?P<subject_logon_id>.*?)\s+(?P<event_details>.*)";
string input = @"User initiated logoff: Subject: Security ID: S-1-5-21-2625066280-1555652605-4253891054-500 Account Name: administrator Account Domain: LANDBW Logon ID: 0xb173ce This event is generated when a logoff is initiated. No further user-initiated activity can occur. This event can be interpreted as a logoff event.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}