re = /(?:(?:\+|00)33|0)\s*[1-9](?:[\s-]\d{2}){4}/m
str = '06 66 59 25 28
0666592528'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end