$re = '/(?:(?:\+|00)33|0)\s*[1-9](?:[\s-]\d{2}){4}/m';
$str = '06 66 59 25 28
0666592528';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);