const regex = /(?:(?:\+|00)33|0)\s*[1-9](?:[\s-]\d{2}){4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:\\+|00)33|0)\\s*[1-9](?:[\\s-]\\d{2}){4}', 'gm')
const str = `06 66 59 25 28
0666592528`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}