re = /(?!^[~!@#$%^&*().]+$)^([\u4e00-\u9fa5]*|[\da-zA-Z~!@#$%^&*.]){0,30}$/
str = '~!@#$%^&**hJUYTREWQWS水电费水电费Dfds'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end