using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^[~!@#$%^&*().]+$)^([\u4e00-\u9fa5]*|[\da-zA-Z~!@#$%^&*.]){0,30}$";
string input = @"~!@#$%^&**hJUYTREWQWS水电费水电费Dfds";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}