const regex = /(?!^[~!@#$%^&*().]+$)^([\u4e00-\u9fa5]*|[\da-zA-Z~!@#$%^&*.]){0,30}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^[~!@#$%^&*().]+$)^([\\u4e00-\\u9fa5]*|[\\da-zA-Z~!@#$%^&*.]){0,30}$', 'g')
const str = `~!@#\$%^&**hJUYTREWQWS水电费水电费Dfds`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}