// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\[[a-zA-Z]+(\|((([a-zA-Z]+)|(\:\:)?)*\=\"[\w\s]*(\:\:\w+)*\"))"#).unwrap();
let string = "// \"/Structure\" package
data-source structurePackage = userPkg/packagedElement[Package|name=\"Structure\"]
synctable-schema ComponentsSchema {
record dim [Class|mse::metaclassName=\"SysML::Blocks::Block\"]{
key column /name as PublicId
column /ownedAttribute[Property|mse::metaclassName=\"MD Customization for SysML::additional_stereotypes::ValueProperty\", name=\"label\"]/defaultValue[LiteralString]/value as Label
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}