$re = '/\[[a-zA-Z]+(\|((([a-zA-Z]+)|(\:\:)?)*\=\"[\w\s]*(\:\:\w+)*\"))/m';
$str = '// "/Structure" package
data-source structurePackage = userPkg/packagedElement[Package|name="Structure"]
synctable-schema ComponentsSchema {
record dim [Class|mse::metaclassName="SysML::Blocks::Block"]{
key column /name as PublicId
column /ownedAttribute[Property|mse::metaclassName="MD Customization for SysML::additional_stereotypes::ValueProperty", name="label"]/defaultValue[LiteralString]/value as Label
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);