const regex = /\[[a-zA-Z]+(\|((([a-zA-Z]+)|(\:\:)?)*\=\"[\w\s]*(\:\:\w+)*\"))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[[a-zA-Z]+(\\|((([a-zA-Z]+)|(\\:\\:)?)*\\=\\"[\\w\\s]*(\\:\\:\\w+)*\\"))', 'gm')
const str = `// "/Structure" package
data-source structurePackage = userPkg/packagedElement[Package|name="Structure"]
synctable-schema ComponentsSchema {
record dim [Class|mse::metaclassName="SysML::Blocks::Block"]{
key column /name as PublicId
column /ownedAttribute[Property|mse::metaclassName="MD Customization for SysML::additional_stereotypes::ValueProperty", name="label"]/defaultValue[LiteralString]/value as Label
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}