re = /hello/m
str = 'Hello world!
I like the word "hello".
I like to say "hello".'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end