package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)hello`)
var str = `Hello world!
I like the word "hello".
I like to say "hello".`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}