$re = '/hello/m';
$str = 'Hello world!
I like the word "hello".
I like to say "hello".';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);