re = /(~~([^~~])*~~)/
str = '<p><span style=\\"color: #44444d; font-family: Roboto, sans-serif; font-size: 16px;\\">Indian women\'s cricket team captain **Mithali Raj** became the all-time highest run-scorer in women\'s ODI __cricket__, going past ~~Charlotte~~ Edwards\' tally of 5,992 runs, against Australia in the ICC Women\'s World Cup on Wednesday. Mithali is also the second player after Charlotte Edwards to score over 500 runs in four different calendar years in women\'s ODI cricket.</span></p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end