using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(~~([^~~])*~~)";
string input = @"<p><span style=\""color: #44444d; font-family: Roboto, sans-serif; font-size: 16px;\"">Indian women's cricket team captain **Mithali Raj** became the all-time highest run-scorer in women's ODI __cricket__, going past ~~Charlotte~~ Edwards' tally of 5,992 runs, against Australia in the ICC Women's World Cup on Wednesday. Mithali is also the second player after Charlotte Edwards to score over 500 runs in four different calendar years in women's ODI cricket.</span></p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}