#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(~~([^~~])*~~)"
Local $sString = "<p><span style=\"color: #44444d; font-family: Roboto, sans-serif; font-size: 16px;\">Indian women's cricket team captain **Mithali Raj** became the all-time highest run-scorer in women's ODI __cricket__, going past ~~Charlotte~~ Edwards' tally of 5,992 runs, against Australia in the ICC Women's World Cup on Wednesday. Mithali is also the second player after Charlotte Edwards to score over 500 runs in four different calendar years in women's ODI cricket.</span></p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")