using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)(?=(\d{3})+$)";
string substitution = @"\1,";
string input = @"3700000000
1000
10000
100000
1000000
10000000
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}