#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d)(?=(\d{3})+$)"
Local $sString = "3700000000" & @CRLF & _
"" & @CRLF & _
"1000" & @CRLF & _
"10000" & @CRLF & _
"100000" & @CRLF & _
"1000000" & @CRLF & _
"10000000" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\1,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)