# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)(?=(\d{3})+$)/\1,/gm;t' <<< "3700000000
1000
10000
100000
1000000
10000000
"