import Foundation
let pattern = #"(?<=\=).+?((?=\t)|(?=\n))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
=friction_t1!$B$2abc =friction_t1!$B$3 =friction_t1!$B$4
=friction_t2!$B$2 =friction_t2!$B$3 =friction_t2!$B$4
=friction_t3!$B$2 =friction_t3!$B$3 =friction_t3!$B$4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)