const regex = /(?<=\=).+?((?=\t)|(?=\n))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\=).+?((?=\\t)|(?=\\n))', 'gm')
const str = `=friction_t1!\$B\$2abc =friction_t1!\$B\$3 =friction_t1!\$B\$4
=friction_t2!\$B\$2 =friction_t2!\$B\$3 =friction_t2!\$B\$4
=friction_t3!\$B\$2 =friction_t3!\$B\$3 =friction_t3!\$B\$4
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}