#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\=).+?((?=\t)|(?=\n))"
Local $sString = "=friction_t1!$B$2abc =friction_t1!$B$3 =friction_t1!$B$4" & @CRLF & _
"=friction_t2!$B$2 =friction_t2!$B$3 =friction_t2!$B$4" & @CRLF & _
"=friction_t3!$B$2 =friction_t3!$B$3 =friction_t3!$B$4" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")