use strict;
my $str = '{"searchRecords":[{"attributes":{"type":"Case","url":"/services/data/v43.0/sobjects/Case/500e000000DmsKDAAZ"},"Id":"500e000000DmsKDAAZ","Case_Status__c":"Open","Emergency_Outage_Case__c":true}]}';
my $regex = qr/"Case_Status__c":"(?<status>.*?)".*?"Emergency_Outage_Case__c":(?<emgcase>.*?)}]}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}