const regex = /"Case_Status__c":"(?<status>.*?)".*?"Emergency_Outage_Case__c":(?<emgcase>.*?)}]}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"Case_Status__c":"(?<status>.*?)".*?"Emergency_Outage_Case__c":(?<emgcase>.*?)}]}', 'gm')
const str = `{"searchRecords":[{"attributes":{"type":"Case","url":"/services/data/v43.0/sobjects/Case/500e000000DmsKDAAZ"},"Id":"500e000000DmsKDAAZ","Case_Status__c":"Open","Emergency_Outage_Case__c":true}]}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}