import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"Case_Status__c\":\"(?<status>.*?)\".*?\"Emergency_Outage_Case__c\":(?<emgcase>.*?)\\}]\\}";
final String string = "{\"searchRecords\":[{\"attributes\":{\"type\":\"Case\",\"url\":\"/services/data/v43.0/sobjects/Case/500e000000DmsKDAAZ\"},\"Id\":\"500e000000DmsKDAAZ\",\"Case_Status__c\":\"Open\",\"Emergency_Outage_Case__c\":true}]}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}