re = /https:\/\/(?P<subdomain>(?:[a-z]+\.)+)?newwheel\.com/m
str = 'https://newwheel.com
https://itlab.newwheel.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end