using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https://(?P<subdomain>(?:[a-z]+\.)+)?newwheel\.com";
string input = @"https://newwheel.com
https://itlab.newwheel.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}