package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https://(?P<subdomain>(?:[a-z]+\.)+)?newwheel\.com`)
var str = `https://newwheel.com
https://itlab.newwheel.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}