$re = '/^01[0125]\d{8}$/m';
$str = '01012345678
01112345678
01212345678
01512345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);