package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^01[0125]\d{8}$`)
var str = `01012345678
01112345678
01212345678
01512345678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}