using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^01[0125]\d{8}$";
string input = @"01012345678
01112345678
01212345678
01512345678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}