import Foundation
let pattern = #"^(?=.{8})(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=[\w\d[:punct:]]+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2_Sh0rt
NO_LOW3RCASE
No_Numbers
n0_uppercase
This_1s_my_p@ssword
This_1s_@n_apple🍎
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)