import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{8})(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=[\\w\\d[:punct:]]+$)";
final String string = "2_Sh0rt\n"
+ "NO_LOW3RCASE\n"
+ "No_Numbers\n"
+ "n0_uppercase\n"
+ "This_1s_my_p@ssword\n"
+ "This_1s_@n_apple🍎";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}