$re = '/^(?=.{8})(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])(?=[\w\d[:punct:]]+$)/m';
$str = '2_Sh0rt
NO_LOW3RCASE
No_Numbers
n0_uppercase
This_1s_my_p@ssword
This_1s_@n_apple🍎';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);