$re = '/^[a-zA-Z0-9]+((_|-|\.)?[a-zA-Z0-9])*$/m';
$str = 'john
john.
john.doe
john80
john_doe
john__doe
TESTUSER_john_doe
_john
john_doe_
john doe
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);