const regex = /^[a-zA-Z0-9]+((_|-|\.)?[a-zA-Z0-9])*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9]+((_|-|\\.)?[a-zA-Z0-9])*$', 'gm')
const str = `john
john.
john.doe
john80
john_doe
john__doe
TESTUSER_john_doe
_john
john_doe_
john doe
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}