import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9]+((_|-|\\.)?[a-zA-Z0-9])*$";
final String string = "john\n"
+ "john.\n"
+ "john.doe\n"
+ "john80\n"
+ "john_doe\n"
+ "john__doe\n"
+ "TESTUSER_john_doe\n"
+ "_john\n"
+ "john_doe_\n"
+ "john doe\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}