re = /^(([a-zA-Zà-ùÀ-Ù]+)(\ )?){0,7}$/m
str = 'Barróso Barróso Barróso Barróso Barróso Barróso Barróso'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end