$re = '/^(([a-zA-Zà-ùÀ-Ù]+)(\ )?){0,7}$/m';
$str = 'Barróso Barróso Barróso Barróso Barróso Barróso Barróso';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);