using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([a-zA-Zà-ùÀ-Ù]+)(\ )?){0,7}$";
string input = @"Barróso Barróso Barróso Barróso Barróso Barróso Barróso";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}