import Foundation
let pattern = #"(?:\$[\d+,]{,100})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Ваша ассоциация наняла рабочего Стэнфорд Флеминг за $208,000,000. Основным соперником была ассоциация Путь со ставкой $195,440,000.
Следующие игроки приняли участие в аукционе:
DikoBrazzers: $28,450,000
рус73: $27,880,000
TANK1515: $20,110,000
Крысолов: $20,000,000
Валентинович 55: $19,860,000
Slepoy 16ru: $15,000,000
Виктор 74: $13,680,000
корефанец: $10,850,000
Папа Djo: $10,210,000
Кадима: $10,020,000
Aleks Mechanic: $9,410,000
пожик47: $9,300,000
super_skif: $7,590,000
Лoки: $5,640,000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)